Home >  > 缠论均线系统指标(飞狐)

缠论均线系统指标(飞狐)

0

第一步:建立一个统计指标【缠中说禅均线分类】,注意,这个指标是用来统计不是用来显示的。

{参数设置:N1=5,N2=13,N3=21,N4=34,N5=55,N6=89,N7=144,N8=233}

ZZD:=REF(L,1)+REF(H,1);
nG:=ZZD-REF(L,2);
nD:=ZZD-REF(H,2);
MA1:=(eMA(nG,N1)+eMA(nd,N1))/2;
MA2:=(eMA(ng,N2)+eMA(nd,N2))/2;
MA3:=(eMA(ng,N3)+eMA(nd,N3))/2;
MA4:=(eMA(ng,N4)+eMA(nd,N4))/2;
MA5:=(eMA(ng,N5)+eMA(nd,N5))/2;
MA6:=(eMA(ng,N6)+eMA(nd,N6))/2;
MA7:=(eMA(ng,N7)+eMA(nd,N7))/2;
MA8:=(eMA(ng,N8)+eMA(nd,N8))/2;
l1:=if(c<ma1 and c<ma2 and c<ma3 and c<ma4 and c<ma5 and c<ma6 and c<ma7 and c<ma8,1,0);
l2:=if(c>=ma1,1,0);
l3:=if(c>=ma2,1,0);
l4:=if(c>=ma3,1,0);
l5:=if(c>=ma4,1,0);
l6:=if(c>=ma5,1,0);
l7:=if(c>=ma6,1,0);
l8:=if(c>=ma7,1,0);
l9:=if(c>=ma8,1,0);
Fl:=if(l1=0,1+l1+l2+l3+l4+l5+l6+l7+l8+l9,1);
l9:fl=9;
l8:fl=8;
l7:fl=7;
l6:fl=6;
l5:fl=5;
l4:fl=4;
l3:fl=3;
l2:fl=2;
l1:fl=1;

   说明一下,这里面的EMA可以改成MA,但如果一个股票上市不足233日,那么用MA统计是无效的,由于近年来新上市的股票比较多,为了将这些股票都统计进来,所以只能折衷地选择了EMA。

   EMA和MA的区别,自己一定要搞清楚,这里就不多讲了。

第二步:添加横向统计

   在横向统计中把刚才从L1到L9的数据分别统计进去。对软件不熟悉的可以去搜索下横向统计功能的运用,这里也不多说。

蜗牛博客补充:

需要统计9次:

Snap108

Snap109

第三步:建立第二个指标,这个指标就是用来显示在软件中的。

   由于L1-L9在KT的横向统计数据中是在data3-data11,所以下面的公式中,各位根据自己添加进横向统计内不同的位置调整estdata的位置。指标取名叫【均线看盘】吧,如下:

多头:=estdata(8)+estdata(9)+estdata(10)+estdata(11);
空头:=-estdata(3)-estdata(4)-estdata(5)-estdata(6)-estdata(7);
L5:estdata(3),COLORRED,linethick0;
L13:estdata(4),COLORwhite,linethick0;
L21:estdata(5),COLORyellow,linethick0;
L34:estdata(6),COLORGREEN,linethick0;
L55:estdata(7),COLORMAGENTA,linethick0;
L89:estdata(8),COLORBLUE,linethick0;
L144:estdata(9),COLORGRAY,linethick0;
L233:estdata(10),COLORCYAN,linethick0;
LS:estdata(11),colorred,linethick0;
stickline(多头>0,0,estdata(8),3,0),COLORBLUE;
stickline(多头>0,estdata(8),estdata(8)+estdata(9),3,0),COLORGRAY;
stickline(多头>0,estdata(8)+estdata(9),estdata(8)+estdata(9)+estdata(10),3,0),COLORCYAN;
stickline(多头>0,estdata(8)+estdata(9)+estdata(10),estdata(8)+estdata(9)+estdata(10)+estdata(11),3,0),COLORRED;
stickline(空头<0,0,-estdata(7),3,0),COLORMAGENTA;
stickline(空头<0,-estdata(7),-estdata(7)-estdata(6),3,0),COLORGREEN;
stickline(空头<0,-estdata(7)-estdata(6),-estdata(7)-estdata(6)-estdata(5),3,0),COLORyellow;
stickline(空头<0,-estdata(7)-estdata(6)-estdata(5),-estdata(7)-estdata(6)-estdata(5)-estdata(4),3,0),COLORwhite;
stickline(空头<0,-estdata(7)-estdata(6)-estdata(5)-estdata(4),- estdata(7)-estdata(6)-estdata(5)-estdata(4)-estdata(3),3,0),COLORRED;
强弱:ma(多头+空头,N),COLORwhite;
M强弱:ma(强弱,M),COLORGREEN;

   至此,该公式就完成了,而横向统计功能中可以查看到具体是哪些股票在哪条均线上的,所以对每日的股票异动情况可以有一个全面的认识,如何运用,可以结合缠师的课文看,以后KT也可以谈谈。

Snap67-14

原作:hxxp://blog.sina.com.cn/s/blog_648a8e4d0100mnmd.html

展示效果:
Snap107

发表评论

*

*