Home >  > Centos安装pyton3.x

Centos安装pyton3.x

自己最近买的一个vps,自带的centos7.9,可是没有python3

于是自己安装:

安装最新版本的EPEL
sudo yum install epel-release

用yum安装python 3.4:

sudo yum install python34(最好改成python36)

注意:上面的安装方法并未安装pip和setuptools,如果你要安装这两个库可以使用下面的命令:

curl -O https://bootstrap.pypa.io/get-pip.py
sudo /usr/bin/python3.4 get-pip.py

可是安装最后两步的时候,出现如下错误:
ERROR: This script does not work on Python 3.4 The minimum supported Python version is 3.6. Please use https://bootstrap.pypa.io/pip/3.4/get-pip.py instead.

后来执行下面的方式来安装:

yum upgrade python-setuptools
yum install python-pip

另外,还有一个问题,这样安装的python要用python3.4来使用。
使用pip也要使用pip3.4 install xxx来使用。

不过后来改为安装python36之后,就没有这些奇怪的问题了。

参考:

https://www.bt.cn/bbs/forum.php?mod=viewthread&tid=21362&highlight=centos%2Bpython3
https://www.cnblogs.com/yangmingxianshen/p/11029532.html

本文暂无标签